An Introduction to Creating Augmented Reality Pages Using Unity
for the Post-Digital Book Arts Project
pdba.usask.ca
by Brandon Piller and Jon Bath

What you will need:

A computer (Windows or Mac) with a camera

A printout of this file - bookbot.pdf

An image of the page we want to use as a trigger (must be .jpg or .png) - bookbot.jpg
This 3D file - bookbot3D.fbx

Step 1:

Unity Personal is free to use for people wanting to start 3D development. This tutorial is built
around Unity version 2018.1.6 but given Unity just did a major update hopefully it will remain
current for some time.

Download and Install Unity 3D - https://unity3d.com/

During the installation process under “Components” be sure to check “Vuforia Augmented
Reality Support.” You may also want to check “Android Build Support” and/or “iOS Build
Support” if you want to develop applications for your phone later. But they are not required for
this tutorial, and they are large files so will slow down the installation download.



http://pdba.usask.ca/assets/ar/bookbot.pdf
http://pdba.usask.ca/assets/ar/bookbot.jpg
http://pdba.usask.ca/assets/ar/bookbot3D.fbx
https://unity3d.com/

Download And Install Unity

Unity component selection

Install  Component Download Size | Installed Size

Unity 2018.1.6f1 1.000 GB 2.43 GB
! Visual Studic for Mac 820 MB 2.30 GB
“ License Documentation 333 MB 802 MB
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Mac | PP Scripting Ba.. 37.3 MB
Summary f 1

Installation
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1*} Indicates that the component raquires Unity to be installed
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@ _t Allows building your Unity projects for the Vuforia-AR platform
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Step 2:

You will need to create an account with Vuforia so that you can get a development key and
upload your images and 3D files.

Go to https://developer.vuforia.com/ (or search for “Vuforia Developer Portal” if this link is not
working)

In the top right click on “Register” and create an account.

Step 3:

While logged into your Vuforia account in the Developer Portal click on the “Develop” tab. You
should automatically be on “License Manager,” but if not select that tab. Then click the “Get
Development Key” button


https://developer.vuforia.com/

s vuforia” peveloper Fortal Hello jonbath ~ | Log Out

Home Pricing Downloads Library Develop Support

License Manager Target Manager

License Manager

Create a license key for your application.

Get Development Key Buy Deployment Key

Name Type Status v Date Modified

Create your first license key

Give your development key an app name of “TestApp” and check the Terms and Conditions
box. Then press the “Confirm” button.

Step 4:

Now click on the “Target Manager” tab and then the “Add Database” button. The database
name should be “TestApp” and the type “Device”. Click the “Create” button. You will be returned
to the “Target Manager” screen. Click on “TestApp”.



s vuforia™ beveloper Portal Hello jonbath ~ | Log Out

Home Pricing Downloads Library Develop Support

License Manager  Target Manager

Target Manager

Use the Target Manager to create and manage databases and targets.

Add Database

Database Type Targets Date Modified

TestApp Device 1 May 30, 2018 10:23

Last updated: Today 137 PM  Refresh

Step 5:

Click the “Add Target” button. We need to specify which image will act as a trigger to display our
3D object. The more unique this image the better the application will be able to recognize it and
use it as a target. The uniqueness of the object will show up as its “rating” later, and you want to
aim for 5 stars. We will use the “bookbot.jpg” file which is available at the top of this tutorial.
Type is “Single Image”, File is “bookbot.jpg”, Width is “5”, and Name is “bookbot”. Click “Add”.
The image will be uploaded and be shown in your list of targets, along with its rating.



Add Target

Type:
J I /. | II\ I.' .-
T T~ --e-.;rf — lL_J'f ¢ s
Single Image Cuboid Cylinder 3D Object
File:
bookbot.jpg Browse...

Jpg or .png (max file 2mb)

Width:
5

Enter the width of your target in scene units. The size of the target should be on the
same scale as your augmented virtual content. Wuforia uses meters as the default unit
scale. The target's height will be calculated when you upload your image.
Name:

bookbot

Mame must be unigue to a database. When a target is detected in your application, this
will be reported in the APL

Cancel Add




Step 6:

We now need to download the database so we can use it in our Unity application. Click the
“‘Download Database (All)” button. Select “Unity Editor” as the development platform and click
the “Download” button. It might take a moment or two for the file to download.

s vuforia™ beveloper Portal Hello jonbath ~ | Log Out

Home Pricing Downloads Library Develop Support

License Manager Target Manager

Target Manager > TestApp

TeStApp Edit Name

Type: Device
Targets (1)
Add Target Download Database (Al
[ Target Name Type Rating Status v Date Modified
O ‘j’; bookbot Single Image S 8 6 8 Active Jun 26, 2018 14:06

Last updated: Today 02:06 PM  Refresh



Download Database

1 of 1 active targets will be downloaded

Name:
TestApp

Select a development platform:

Android Studio, Xcode or Visual Studio

£ Unity Editor

Cancel Download

Step 7

Open the Unity application, but keep the Vuforia window open in your web browser because we
will need it for a later step. If it is your first time opening the application you will need to create a
Unity ID. Under “License Management” select “Unity Personal” and then “| don’t use Unity in a
professional capacity.” After activation click the “Start Using Unity” button.

Step 8

Click the “New Project” button. Call your project “TestApp”, use the template “3D”, and select a
folder you want to save it in. Switch “Enable Unity Analytics” off. The click the “Create Project”
button. Unity will start (may take a few moments).



@ Unity 2018.1.6f1

PrOjECtS Learn B New p\] Open -i\- My Account

TestApp 3D v

3 /Users/admin/Desktop

{. OFF:_‘_I Enable Unity Analytics (7))

c

Step 9

Although we downloaded the Vuforia components in Step 1, we still need to tell Unity to enable
them. In the top menu bar go to File -> Build Settings . A window will pop open. In the bottom
left of that window click the “Player Settings” button. Information will appear in the right side of
the Unity window. Click the bottom tab, “XR Settings”, and then check the “Vuforia Augmented
Reality” box. You will need to agree to Vuforia’s Terms and Conditions. You can then close the
Build Settings window.




[ settings for PC, Mac & Linux Standalone
[ Icon

[ Resolution and Presentation

| splash image

Step 10

The next step is to import our Vuforia assets. In the top menu select Assets -> Import Package
-> Custom Package . Navigate to wherever you downloaded the Vuforia database, called
“TestApp.unitypackage” if you have been using our suggested names, and open it. A window
called “Import Unity Package” displaying the contents of the package will appear. Click “Import”.
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Step 11

In the Unity “Scene” window click on the movie camera. In the “Inspector” panel on the right it
will show that you've clicked on “Main Camera”. Press the “Delete” button -- “Command +
Delete” if you are on a Mac. The camera should disappear.
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Step 12

We now need to add the Augmented Reality camera. In the top menu got to “GameObiject ->
Vuforia -> AR camera”. If this is your first time doing this step it will need to import some assets.
Press the “Import” button in the pop-up window. You'll get to watch some progress bars and
then the camera will appear in the scene.

Step 13

Go back to the Vuforia Developer Portal tab in your web browser. In the “License Manager” tab
click on “TestApp”. Copy all the text in the gray rectangle by selecting it and using CTRL+c
(Command+c on a Mac).



s vuforiar peveloper Portal Hello jonbath ~ | Log Out

Home Pricing Downloads Library Develop Support

License Manager ~ Target Manager

License Manager > TestApp

TeStApp Edit Name Delete License Key

License Key Usage

Please copy the license key below into your app

AcEjakX/////ABRABmX4Pyc51LEm11sRQ1tJOLXVsnM/2A+aa6oCWH
2kPCU+£fv6/+RUVpDkd2rGQg+02ikgQLadnOwNO8igL5XFbG+KXx4
U4rwUsNGDEnVkzt7iTodxFOVOWwsp8zdF5WbxsUQggD36J4k9tay
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1/12czydHx21L2u05k4pu¥YbUT4v19XUDU3FI60ktkMEPE3uPkaWy
LL3CZpYUXEeYvDniZ+

Type: Develop
Status: Active
Created: Jun 26, 2018 13:34

History:
License Created - Today 13:34

Step 14

Go back to Unity. Click on the camera in the Scene window. The right Inspector panel will show
“‘“ARCamera”. Near the bottom of the Inspector panel click the “Open Vuforia Configuration”
button.
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The Inspector panel will change to show you the Vuforia configuration. In the “App License Key”
textbox near the top of the Inspector paste the license key by clicking in the box and pressing
“Control+v” or “Command+v” on a Mac. You DO NOT need to click the “Add License” button.
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Step 15

The next step is to tell the camera which image to look for to trigger the Augmented Reality. In
the top menu go to “GameObject->Vuforia->Camera Image->Camera Image Target”. In the right
Inspector panel change the “Type” from “User Defined” to “Predefined”. The Database field will
be autopopulated with “TestApp” and the Image Target with “bookbot”. The bookbot image will
appear in the scene window.
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Step 16

For our first test we are just going to have a 3D cube appear when the camera detects the
bookbot image. In the top menu select “GameObject->3D Object->Cube”. A cube will appear in
the middle of the scene. We need to attach it to the image target so it appears and disappears
whenever the target is detected by the camera. In the left “Hierarchy” panel click on “Cube” and
drag it onto “ImageTarget”. It will now be a sub-item, or child, of the image target. In the right
Inspector panel you can set its Y position to “.5” and Z to “2” to have it appear entirely above the
image of bookbot’s head. Or in the Scene window you can use the green, red and blue handles
to drag it around the scene. Make sure it is positioned somewhere above the bookbot image.
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Step 17

It's time to try things out. Press the “Play” arrow, the right facing arrow button, located above the
Scene window. It will take a moment to build the file and then the feed from your camera will
appear in the Scene window. Hold up your printout of bookbot. A 3D cube will appear where you
placed it on the image. Congratulations, you've augmented reality! To stop the simulation press
the “Play” arrow again.
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Step 18

Once you've tired of basic shapes you can also use 3D assets for your augmented reality.
Select the cube in the Scene and delete it (with the Delete key or Command+Delete on Mac).
Download the “bookbot3D.fbx” file at the top of this tutorial. In the top menu use “Assets->Import
New Asset” and then choose “bookbot3D.fbx”. “bookbot3D” will appear in the Assets panel in
the bottom middle of the window. You may need to click on the “Assets” folder in the bottom left
panel first to be able to see your imported assets. Drag “bookbot3D” up onto “ImageTarget” in
the left panel. BookBot will appear in the Scene window but will be very large. Using the
Inspector panel you can Position, Scale, and Rotate the model. Setting the X,Y and Z scale to
0.05 will make BookBot a manageable size. Use the “Play” arrow to try things out.



@ \Unity File Edit Assets GameObject Component Window Help
Unity 2018.1.6f1 Personal (64bit) - SampleScene.unity - TestApp - PC, Mac & Linux Standalone (Personal) <OpenGL 4.1>

8 Inspector
W= [bookhot3D | [ static

Tag [ Unagged 4| Layer| Default =
Model [ Select | Revert L Open J

A~ Transform @
Position x[-0.113 ¥[-0098  |Zz[-0.139
xo__ 1v}m z0
xo5s oo 205
[ None (Runtime Animator Controller) ©
¢bookbo3DAvatar | ©
Apply Root Motion - |
Update Mode Normal o
Culling Mode Cull Update Transforms 1]

Clip Count: 0
Curves Pas: 0 Quat 0 Euler: 0 Scale: 0 Muscles: 0 Generic: 0 PPr: 0
Curves Count: 0 Constant: 0 {0.0%) Dense: 0 (0.0%) Stream: 0 {0.0%)

[ Add Compenent |

v & vuforia
I G CylinderTargetTextures
Emulator
» & ForPrint
¥ (& ImageTargetTextures
&3 Testapp

&5 VuforiaEmulator Waving.

i A
&5 VuforiaMars_ModelTarget
i VuforiaMars_VuMark
» & Models.

W Unity rHile Edit Assels GameOUbject U window Help
®0e Unity 2018.1.6f1 Personal (64

) - SampleScene.unity - TestApp - PC, Mac & Linux Standalone (Personal) <OpenGL 4.1>




Step 19 - Next steps
Here are some other resources we have found useful:

How to deploy for IOS
https://medium.com/@MissAmaraKay/build-your-first-ai-ar-app-on-unity-8c12895687fa
https://unity3d.com/learn/tutorials/topics/mobile-touch/building-your-unity-game-ios-device-testin
o]
https://mobile-ar.reality.news/how-to/arkit-101-using-unity-arkit-plugin-create-apps-for-iphone-ip
ad-0178022/

How to deploy for Android
https://www.sitepoint.com/how-to-build-an-ar-android-app-with-vuforia-and-unity/

For Hololens( the set up is very similar to the set up for phones)
https://www.youtube.com/watch?v=u6fT2zaEKVc

For learning about virtual buttons
https://www.youtube.com/watch?v=ElmzIlq6stNI

For additional help
https://docs.unity3d.com/Manual/vuforia_tips.html
https://library.vuforia.com/articles/Training/getting-started-with-vuforia-in-unity.html

alternatives to Vuforia
https://unity3d.com/how-to/create-AR-games-in-Unity-efficiently
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